These tips came from Tech Target

Disable motherboard graphics on Ultra5/10

(Caleb Warner)
eeprom pcib-probe-list=1,3 ; reboot -- -r


Quick duplication of disk labels

(Eddie Anzalone)
prtvtoc -h /dev/dsk/c0t0d0s2 | fmthard -s - /dev/rdsk/c0t1d0s2


Determine network boot config

(B. Costello)
bpgetfile
This is useful in tracking down why a host will not boot from the network or seems to be loading a different config than intended.
To find out what bootp server your target machine will get this information from, omit the server: bpgetfile root ''
ie: bpgetfile root ''
client returns: bpserver 192.168.0.10 /jumpstart/Solaris_8/Tools/Boot
where bpserver is the responding bootparam server, ip address is the ip of the server and the /jumpstart/Sol... is the shared nfs volume that the client should mount
valid file_names are: root - miniroot install - location to install from sysid_config - location of your sysidcfg file install_config - location of the rules.ok file


syslogd that doesn't listen

(Michael Randall)
in solaris 8, syslogd -t will not bind to UDP/514


Stronger TCP connection numbers

(Michael Randall)
set TCP_STRONG_ISS=2 in /etc/default/inetinit and reboot


change banners

(Gunther Vanaken)
set BANNER= in /etc/default/telnetd and /etc/default/ftpd
set O SmtpGreetingMessage= in /etc/mail/sendmail.cf


Allow users to give away files

(David Cashion)
to allow users to run chown, set rstchown=0 in /etc/system


using a CD-R

(Greg Kranz)
Install the CD Read/Write software from the Software Supplement CD
/usr/bin/cdrw -i verify CD-R is available
create an ISO image with:
mkisofs -A "vold_mount_dir_name" -l -r -d -L -o /image/name src_dir
write the image to CR-R:
/usr/bin/cdrw -i /image/name


using ACLs

(Sean Quaint)
Tip: Solaris' Access Control List mechanism is an easy was to fine tune who has access to which files and/or commands. This tip illustrates how to use ACL templates to quickly assign complex permissions to a file.
Be sure to keep ACL_templates in a secured directory and should be read-only by the owner.
bash-2.03$ touch file1
bash-2.03$ setfacl -m u:joe:6,g:sysadmin:6,m:6 file1
bash-2.03$ getfacl file1
# file: file1
# owner: squaint
# group: other
user::rw-
user:joe:rw-     #effective:rw-
group::r--     #effective:r--
group:sysadmin:rw-     #effective:rw-
mask:rw- other:r--
bash-2.03$ getfacl file1 > ACL_template
bash-2.03$ setfacl -f ACL_template file2
bash-2.03$ getfacl file2
# file: file2
# owner: squaint
# group: other
user::rw-
user:joe:rw-     #effective:rw-
group::r--     #effective:r--
group:sysadmin:rw-     #effective:rw-
mask:rw- other:r--


disable STOP-a

(Siddhartha Jain)
kbd -a disable


check current system run level

who -r
see also who -a


changing process priorities

renice and priocntl